Jaxx Development Update: Android 5.1

Jaxx Development Update: Android 5.1

An announcement from our Development team: Jaxx will no longer be available on devices running versions older than 5.1 of the Android OS. The Android OS releases known as Lollipop were released as early as 2014. Devices running Android OS versions that predate Lollipop (5.1) do not have the ability to handle the latest version of our Jaxx Wallet.

Users on Android 5.1 or older who have not backed up their 12-word backup phrase and who have also not ever paired their wallet on any of the other platforms Jaxx supports – iOS, Mac, Linux, Windows and Chrome Extension – should reach out to our support team for help.